Seznam všech nainstalovaných balíčků s centrem CentOS 7

Seznam všech nainstalovaných balíčků s centrem CentOS 7

V tomto krátkém tutoriálu vám ukážeme, jak uvést všechny nainstalované balíčky s přístupem yum CentOS 7 . Yum je výchozí správce balíčků používaný v CentOSu, který slouží k interakci s oběma jednotlivými balíky RPM a mnoha repozitáři. Tento tutoriál byl napsán pro CentOS 7, ale příkazy v tomto tutoriálu by měly fungovat na libovolném serveru s nainstalovaným systémem Redhat, CentOS nebo Fedora.
Chcete-li uvést všechny nainstalované balíky na VPS s nainstalovaným CentOS 7, můžete použít příkaz příkazového řádku "yum list installed". Uvádí seznam všech nainstalovaných balíčků RPM na serveru v abecedním pořadí podle velikosti písmen. Například:

instalovaný seznam
Installed Packages
GeoIP.x86_64                                                                    1.5.0-11.el7                                                               @base
ImageMagick.x86_64                                                              6.7.8.9-15.el7_2                                                           @C7.2.1511-updates
OpenEXR-libs.x86_64                                                             1.7.1-7.el7                                                                @C7.0.1406-base
acl.x86_64                                                                      2.2.51-12.el7                                                              installed
apr.x86_64                                                                      1.4.8-3.el7                                                                @base
apr-devel.x86_64                                                                1.4.8-3.el7                                                                @base
apr-util.x86_64                                                                 1.5.2-6.el7                                                                @base
apr-util-devel.x86_64                                                           1.5.2-6.el7                                                                @base
aspell.x86_64                                                                   12:0.60.6.1-9.el7                                                          @C7.0.1406-base
audit-libs.x86_64                                                               2.6.5-3.el7_3.1                                                            @updates
autoconf.noarch                                                                 2.69-11.el7                                                                @base
autogen-libopts.x86_64                                                          5.18-5.el7                                                                 @C7.0.1406-base
automake.noarch                                                                 1.13.4-3.el7                                                               @base
avahi-libs.x86_64                                                               0.6.31-17.el7                                                              @base
awstats.noarch                                                                  7.6-3.1.el7                                                                @epel
basesystem.noarch                                                               10.0-7.el7.centos                                                          installed
bash.x86_64                                                                     4.2.46-21.el7_3                                                            @updates
bc.x86_64                                                                       1.06.95-13.el7                                                             @C7.0.1406-base
bind.x86_64                                                                     32:9.9.4-50.el7_3.1                                                        @updates
bind-libs.x86_64                                                                32:9.9.4-50.el7_3.1                                                        @updates
bind-license.noarch                                                             32:9.9.4-50.el7_3.1                                                        @updates
bind-utils.x86_64                                                               32:9.9.4-50.el7_3.1                                                        @updates
binutils.x86_64                                                                 2.25.1-22.base.el7                                                         @base
bzip2-libs.x86_64                                                               1.0.6-13.el7                                                               @base
ca-certificates.noarch                                                          2017.2.14-70.1.el7_3                                                       @updates
cairo.x86_64                                                                    1.14.2-1.el7                                                               @C7.2.1511-base
centos-logos.noarch                                                             70.0.6-3.el7.centos                                                        @updates
centos-release.x86_64                                                           7-3.1611.el7.centos                                                        @base
chkconfig.x86_64                                                                1.7.2-1.el7_3.1                                                            @updates
clamav-data.noarch                                                              0.99.2-8.el7                                                               @epel
clamav-filesystem.noarch                                                        0.99.2-8.el7                                                               @epel
clamav-lib.x86_64                                                               0.99.2-8.el7                                                               @epel
clamav-server.x86_64                                                            0.99.2-8.el7                                                               @epel
clamav-update.x86_64                                                            0.99.2-8.el7                                                               @epel
clucene-core.x86_64                                                             2.3.3.4-11.el7                                                             @base
composer.noarch                                                                 1.5.1-1.el7.remi                                                           @remi
coreutils.x86_64                                                                8.22-18.el7                                                                @base
cpio.x86_64                                                                     2.11-24.el7                                                                @base
....
which.x86_64                                                                    2.20-7.el7                                                                 @base
xorg-x11-font-utils.x86_64                                                      1:7.5-20.el7                                                               @C7.2.1511-base
xz.x86_64                                                                       5.2.2-1.el7                                                                @base
xz-devel.x86_64                                                                 5.2.2-1.el7                                                                @base
xz-libs.x86_64                                                                  5.2.2-1.el7                                                                @base
yum.noarch                                                                      3.4.3-150.el7.centos                                                       @base
yum-metadata-parser.x86_64                                                      1.1.4-10.el7                                                               installed
yum-plugin-fastestmirror.noarch                                                 1.1.31-40.el7                                                              @base
yum-utils.noarch                                                                1.1.31-40.el7                                                              @base
zip.x86_64                                                                      3.0-11.el7                                                                 @base
zlib.x86_64                                                                     1.2.7-17.el7                                                               @base
zlib-devel.x86_64                                                               1.2.7-17.el7                                                               @base which.x86_64 2.20-7.el7 @ báze xorg-x11-font-utils.x86_64 1: 7.5-20.el7 @ C7.2.1511-base xz.x86_64 5.2.2-1.el7 @ báze xz-devel.x86_64 5.2.2-1.el7 @base xz-libs.x86_64 5.2.2-1.el7 @ báze yum.noarch 3.4.3-150.el7.centos @base yum-metadata-parser.x86_64 1.1.4-10.el7 nainstalován yum-plugin-fasttestmirror.noarch 1.1.31-40. el7 @base yum-utils.noarch 1.1.31-40.el7 @base zip.x86_64 3.0-11.el7 @base zlib.x86_64 1.2.7-17.el7 @base zlib-devel.x86_64 1.2.7-17.el7 @base

Jak můžete vidět z výstupu, tento příkaz příkazové řádky vám ukáže dlouhý seznam všech nainstalovaných balíků, včetně názvu balíčku, verze balíku a názvu repozitáře, ze kterého byl balíček nainstalován.
Nebo použijte méně na konci tohoto příkazu:

instalovaný seznam | méně

Umožní vám zobrazit současně jednu obrazovku.
Chcete-li zobrazit všechny balíčky, nainstalované i dostupné, můžete použít následující příkaz:

dostupný seznam

Rovněž můžete použít grep pro filtrování výstupů a seznam pouze specifických balíčků. Chcete-li například uvést všechny nainstalované balíčky PHP, použijte následující příkaz:

instalovaný seznam | grep -i php
php-php-gettext.noarch 1.0.12-1.el7 @epel php-tcpdf.noarch 6.2.13-1.el7 @epel php-tcpdf-dejavu-sans-fonts.noarch 6.2.13-1.el7 @epel php70u-bcmath.x86_64 7.0.28 -1.ius.centos7 @ius php70u-cli.x86_647.0.28-1.ius.centos7 @ius php70u-common.x86_64 7.0.28-1.ius.centos7 @ ix php70u-fpm.x86_64 7.0.28-1.ius.centos7 @ius php70u-fpm-nginx.noarch 7.0.28-1.ius.centos7 @ ix php70u-gd.x86_64 7.0.28-1.ius.centos7 @ ix php70u-json.x86_64 7.0.28-1.ius.centos7 @ius php70u-ldap.x86_64 7.0.28 -1.ius.centos7 @ius php70u-mbstring.x86_647.0.28-1.ius.centos7 @ius php70u-mcrypt.x86_64 7.0.28-1.ius.centos7 @ius php70u-mysqlnd.x86_64 7.0.28-1.ius.centos7 @ius php70u-opcache.x86_64 7.0.28-1.ius.centos7 @ ix php70u-pdo.x86_64 7.0.28-1.ius.centos7 @ius php70u-pear.noarch 1: 1.10.5-1.us. centos7 @ius php70u-process.x86_64 7.0.28-1.ius.centos7 @ius php70u-tidy.x86_64 7.0.28-1.ius.centos7 @ius php70u-xml.x86_64 7.0.28-1.ius.centos7 @ius php70u-xmlrpc.x86_64 7.0.28-1.ius.centos7 @ius phpMyAdmin.noarch 4.4.15.10-2.el7 @epel

původní článek

Napsat komentář