Adobe har besluttet at støtte Flash Player på Linux igen

Adobe Flash Linux

Adobe elsker Linux igen

Uhh, det er en underlig en.

Adobe har meddelt, at den planlægger at begynde at støtte Adobe Flash for Linux - 4 år efter, at den forladte Flash på Linux.

Tilbage i 2012 sagde virksomheden, at det ikke ville gøre nyere versioner af NPAPI Flash Player-plugin'et tilgængeligt på Linux og ville kun give sikkerhedsopdateringer til Flash Player 11.2 til 2017.

Men i en lille meddelelse lavet på sin blog i sidste uge har Adobe gjort en u-turn på begge beslutninger og leveret en betaversion af Adobe Flash 23 til Linux.

Vent, hvad?!

Yup, Adobe har meddelt, at det er at genoptage supporten af ​​NPAPI Flash Player plugin på Linux.

Desuden vil det ikke stoppe med at levere sikkerhedsopdateringer i 2017 som tidligere meddelt: "Tidligere meddelte vi, at NPAPI Linux-udgivelser ville stoppe i 2017. Dette er ikke længere tilfældet ", skriver de.

En ny beta af NPAPI-plugin'et er blevet stillet til rådighed for download. Selvom det ikke virker i apps, der har depreceret eller fjernet NPAPI-plugins (som Google Chrome) bør Spil godt i Mozilla Firefox og andre apps.

Adobe siger, at den planlægger regelmæssigt at opdatere både NPAPI og PPAPI versionerne af Flash Player til Linux.

Wow! Gå Adobe, højre ?!

Nah, ikke helt.

Se, mens Adobe planlægger at holde disse nye opdateringer opdateret og synkroniseres med store udgivelser på Windows og Mac ikke planlægger at understøtte eller tilføje avancerede funktioner og funktioner, som DRM, GPU acceleration, Stage 3D, osv. til NPAPI-versionen på Linux.

Dem, der søger at Niveauet af funktionalitet anbefales, siger Adobe, til at bruge PPAPI-versionen af ​​Flash Player.

Hvorfor har Adobe gjort dette?

Adobe siger, at det er "... at flytte [NPAPI Linux Flash Player plugin] fremad og synkroniseret med den moderne udgivelsesgren" at "forbedre sikkerheden og give yderligere begrænsning til Linux-fællesskabet."

Hvilket er et modent svar - det er aldrig let at (slags) indrømme, at du havde taget fejl!

De fortsætter med at beskrive denne ændring som "... primært et sikkerhedsinitiativ" og sige, at "den nye NPAPI-bygning udgør et vigtigt fremskridt i funktionalitet, stabilitet og sikkerhed."

Jeg tror jeg allerede kører ny flash på Linux?

Hvis du bruger Google Chrome, gør du det!

Linux-brugere har kunnet bruge en opdateret version af Flash (bygget som et PPAPI-plugin) takket være Google, som ikke kun vedligeholder det, men som standard sender det som en del af Google Chrome og Chrome OS.

Mange Linux-distributioner, herunder Ubuntu, tilbyder en "hjælper" -pakke, der overfører Chrome, udpakker PPAPI Flash-plugin og gør den tilgængelig til andre applikationer, der skal bruges.

Hvor kan jeg downloade det?

Du kan downloade binarier fra NPAPI Adobe Flash player beta fra Adobe Labs hjemmeside. Disse er kun tilgængelige som 32-bit og 64-bit binære filer (ikke en installationspakke) og siges ikke at fungere med Fedora (eller Fedora-baserede distributioner).

Download Adobe Flash Player Beta

For mere om Adobes u-turn check ud dette indlæg på embedsmanden Adobe Flash Player blog.

kilde: Adobe (via Phoronix)

Giv en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.