Sådan fixes (irriterende) 'Kunne ikke hentes' Chrome apt Error

chrome drops 32bit Linux supportGoogle meddelte planer om at afbryde 32-bit Google Chrome til Linux denne marts, og det er på bange.

Søgemaskinen har trukket 32-bit Chrome-build fra det officielle Chrome-repo, som tilføjes til Ubuntu Software Sources, når appen installeres første gang.

Nogle 64-bit Ubuntu-systemer, der er fanget i krydshårene i afskrivningen, kaster nu en lille, men alligevel meget irriterende fejl, når de udfører en passende opdatering.

'Fejlfinding til at hente fejl, der vises i Terminal, siger:

"Kunne ikke hente http://dl.google.com/linux/chrome/deb/dists/stable/Release Unable for at finde forventet post 'main / binær-i386 / Pakker' i Release-fil (Forkert sources.list-indtastning eller fejlformet fil)"

Alternativt kan du se:

Skipping erhverver af konfigureret fil 'main / binær-i386 / Packages' som depot 'http://dl.google.com/linux/chrome/deb stable InRelease' understøtter ikke arkitekturen 'i386'

Hvis du ser en af ​​disse to fejl ikke panik. Det er nemt at rette fejlen 'failed to get' og 'skipping acquire' problemet. Alt det kræver er 30 sekunder og et par simple tegn ...

'Opløsningen tager kun 30 sekunder at udføre, så ingen mere irriterende fejl.'

Fix 'Failed to Hente' Apt Error på Ubuntu

Tipet kommer til os ved hjælp af OMG! Ubuntu! læser Santiago Batista, der forklarer situationen i sin e-mail til os:

"Da Google har tabt support for 32-bit Chrome på Linux, opstår der en fejl, når der opdateres i 64-bit-systemer (med multi-ark aktiveret).

"Løsningen," siger han, "er at ændre sources.list-filen til Chrome."

Men hvordan gør du det?

Vi kan redigere sources.list på en række forskellige måder. Nogle af disse finder sted på kommandolinjen, andre via en GUI.

Du har muligvis din egen foretrukne metode, men for denne gennemgang vil jeg bruge Gedit.

1. Åbn et nyt Terminal vindue og kør følgende kommando (forudsat at du er på den stabile kanal, hvis ikke, se den fremhævede kommentar):

sudo gedit /etc/apt/sources.list.d/google-chrome.list

2. I den tekstfil, der åbnes, rediger filen, så linjen læser:

deb [arch = amd64] http://dl.google.com/linux/chrome/deb/ stable main

Den eneste tilføjelse, du skal lave, er at gå ind i [amd64] arkitekturen efter 'deb', men forud for 'http'en. Du må ikke redigere eller erstatte anden tekst i denne fil.

3. Hit Save. Luk Gedit vinduet.

Gå nu tilbage til Terminal og opdatér din pakker liste ved at køre:

sudo apt-get update

APT-fejlen fejler ikke at hente, vises ikke længere.

Giv en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.