Fix "Kan ikke blande inkompatibelt Qt-bibliotek" på KDE Neon 5.10

Jeg fandt ud af, at systemet efter installation af KOrganizer på KDE Neon 5.10 oplevede en fejl, hvor jeg ikke kan logge ind korrekt på skrivebordet. Den eneste anelse er en fejlmeddelelse, der siger, at der er uforenelighed i Qt-biblioteksversioner. Løsningen i mit tilfælde er ved apt-get opgradering:
Problemer

  1. KOrganizer kunne ikke starte.
  2. KDE-programmer kunne ikke starte (Spectacle and Dolphin).
  3. Efter genstart mislykkedes det at logge ind på skrivebordet. Det viser kun blank skærm (undtagen jeg kan stadig logge ind på tty).

Min specifikation: Neon 5.10 operativsystem på en 64bit bærbar computer.
Fejl besked
Kan ikke blande inkompatibelt Qt-bibliotek (version 0x50701) med dette bibliotek (version 0x50900)
Løsning
Tidligere installerede jeg igen KDE Neon 5.10 på grund af dette problem. Én gang installeret, jeg stødte på dette problem igen! Men endelig erkender jeg, at jeg bare skal opgradere alle pakker for at løse det:

sudo apt-get upgrade

Bemærk: Jeg gjorde ikke apt-get dist-upgrade og det er OK. Så i dette tilfælde er dist-upgrade-kommandoen ikke nødvendig.

Kilde

Giv en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.