GNU Octave 5.1.0 Udgivet med HiDPI Support (Howto Installer)

GNU Octave 5.1.0 blev annonceret i går som en ny stor udgivelse med forbedringer af Matlab-kompatibilitet og mange nye og forbedrede funktioner.

GNU Octave 5.1.0 udgivne højdepunkter:

  • Tilføjer HiDPI support
  • Kræver Qt4> = 4.8, selvom Qt5 foretrækkes.
  • Tilføjer mange nye funktioner.
  • Udskrivning til rasterformater bruger som standard en OpenGL-baseret metode
  • Nye udskriftsindstillinger til PDF og PostScript
  • En ny printerenhed producerer ASCII-kunst til plot
  • FFTW biblioteket er nu påkrævet til FFT beregninger
  • OSMesa-biblioteket bruges ikke længere.

Sådan installeres Octave 5.1 i Ubuntu 18.04 / 16.04:

1. Første åben terminal (Ctrl + Alt + T) og sørg for, at Flatpak support er aktiveret ved at køre kommandoen:

sudo apt-get install flatpak

For Ubuntu 16.04 skal du tilføj Flatpak PPA først for at kunne installere Flatpak ramme.

2. Tilføj derefter Flathub-depotet, det bedste sted at få Flatpak apps:

flatpak remote-add -if-ikke-eksisterende flathub https://flathub.org/repo/flathub.flatpakrepo

3. Endelig installer GNU Octave fra Flathub-depotet:

flatpak installere flathub org.octave.Octave

Det tager et par minutter at downloade flatpak-pakken og afhængighedsplatformen, hvis du installerer den første gang.

Ligesom normale applikationer kan du starte Octave fra Gnome app launcher:

Flatpak eksisterer sammen med traditionel Octave-pakke. Du kan alternativt køre det i kommandolinjen:

flatpak køre org.octave.Octave

Afinstaller:

Du kan fjerne Octave flatpak-pakken ved at køre kommandoen:

flatpak afinstallere org.octave.Octave

Og fjern flatpak support, hvis du vil:

sudo apt-get fjerne flatpak

Oprindelig artikel

Giv en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.