Sådan installeres sK1 Vector Graphic Editor i Ubuntu 14.04

I GNU / Linux verden er der Inkscape, den mest populære vektorredaktør. Men sandsynligvis ved mange brugere ikke om en anden gratis software, der hedder sK1. Det er en fantastisk vektor grafisk editor fra den samme udvikler af UniConvertor (kendt som gratis CorelDRAW CDR format importør bibliotek). sK1 er GNU GPL v2, så det er sikkert for os. Desværre har Ubuntu officielle depot ingen pakke til sK1, og selv er der ingen PPA endnu, så vi skal installere det fra en anden kilde. Her instruktionerne om, hvordan du installerer sK1 i Ubuntu 14.04 og derover. Tak for sK1 Project.

1. Download sK1 pakke

Gå til http://sk1project.org/modules.php?name=Products&product=sk1&op=download og download 14.04-pakken. Hvis du bruger nyere version, skal du downloade den relevante version.

2. Udfør dpkg

Udfør under dpkg kommando. Vi antager, at du gemmer pakken i din $ HOME-mappe.

sudo dpkg -i python-sk1-0.9.3_1ubuntu1_14.04_i386.deb

Bemærk: Dette vil pakke ud og gøre noget teknisk for at installere pakken. Dette vil mislykkes, fordi denne pakke nævner nogle afhængigheder, mens dpkg ikke kan løse afhængigheder. Der vises sikkert fejlmeddelelser, men dpkg markerer dem alle for apt-get.

3. Se fejlmeddelelser

Du skal se fejlmeddelelser som denne. Bare rolig, det er normalt.

Vælger tidligere ikke valgt pakke python-sk1. (Læsning database ... 174918 filer og mapper installeret i øjeblikket.) Forbereder at udpakke python-sk1-0.9.3_1ubuntu1_14.04_i386.deb ... Udpakning af python-sk1 (0.9.3) ... dpkg: afhængighedsproblemer forhindrer konfiguration af python-sk1: python- sk1 afhænger af python-tk; Men: Pakke python-tk er ikke installeret. dpkg: fejlbehandlingspakke python-sk1 (--install): afhængighedsproblemer - forlader ukonfigureret Behandlingsudløsere til gnome-menuer (3.10.1-0ubuntu2) ... Behandlingsudløsere til desktop-fil-utils (0.22-1ubuntu1) ... Behandling udløser til bamfdaemon (0.5.1 + 14.04.20140409-0ubuntu1) ... Genopbygning /usr/share/applications/bamf-2.index ... Behandlingsudløsere til mime-support (3.54ubuntu1) ... Der opstod fejl under behandlingen: python-sk1

Udfør apt-get

Udfør under apt-get kommando. Den vil læse dpkg-mærker før, kontrollere afhængighedsproblemet ved sK1, løse det og downloade dem alle, så sK1 vil blive installeret. I Ubuntu 14.04 har den brug for 22 KB data til at downloade.

sudo apt-get -f installation

Giv en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.