Hvorfor Oracle Java 7 og 6 installatører ikke længere arbejde

Oracle Java
Fordi jeg har modtaget mere end 50 e-mails om dette, skønt jeg selv ville skrive et indlæg om det for at rydde op for alle.
Mens Oracle Java 6 og 7 ikke understøttes i et stykke tid, var de stadig tilgængelige til download på Oracle's websted indtil for nylig.
Binærerne blev imidlertid fjernet for ca. 10 dage siden (?), Så Oracle Java (JDK) 6 og 7-installatører, der er tilgængelige i WebUpd8 Oracle Java PPA, fungerer ikke længere.
Oracle Java 6 og 7 er nu kun tilgængelige for dem med en Oracle Support-konto (som ikke er gratis), så jeg kan ikke støtte dette til PPA-pakkerne.
Fra Oracle Java downloads side:

“Opdateringer til Java SE 7 frigivet efter april 2015, og opdateringer til Java SE 6 frigivet efter april 2013 er kun tilgængelige for Oracle-kunder via My Oracle Support (kræver support login).
Java SE Advanced tilbyder brugerne kommercielle funktioner, adgang til kritiske fejlrettelser, sikkerhedsrettelser og generel vedligeholdelse ”.

Det anbefales stærkt, at du opdaterer til Oracle Java 8. Se de følgende artikler for, hvordan du installerer Oracle Java 8 i Ubuntu (eller Linux Mint og derivater) eller Debian via PPA.
Hvis du har en Oracle Support-konto, og du virkelig har brug for Oracle JDK 6 eller 7, kan du få installatørerne fra WebUpd8 PPA til at arbejde ved at downloade binærerne og placere dem i følgende mappe:

  • / var / cache / oracle-jdk6-installer / til JDK 6 (du har brug for version 6u45)
  • / var / cache / oracle-jdk7-installer / til JDK 7 (du har brug for version 7u80 til 32bit og 64bit eller 7u60 til arm)

... og installer derefter pakken oracle-java6-installer eller oracle-java7-installer.

Oprindeligt udgivet på WebUpd8: Daily Ubuntu / Linux nyheder og applikations anmeldelser.

Efterlad en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.