OS X installatører downloadet før februar 14 ikke længere arbejde efter certifikatopdatering

Tilbage i februar blev Apples verdensomspændende udviklercertifikat designet til at verificere tredjeparts apps og -tjenester, udløbet, der kræver, at Apple udsteder et nyt certifikat for udviklere at bruge.

Som påpeget af godbidder (Via Ars Technica) En bivirkning ved udskiftningen af ​​certifikatet forårsager, at ældre OS X-installatører ikke klarer at starte. OS X installationsfiler, der er hentet fra Mac App Store før februar 14, 2016 og gemt på en computer eller et USB-drev, er ikke længere funktionelle. Dette omfatter installationsfiler til OS X El Capitan og ældre versioner af OS X som Mavericks og Mountain Lion.

oldosxinstallerBillede via godbidder

Brugere, der holder OS X-installatører til rådighed eller har oprettet USB-installationsdiske i tilfælde af nødsituationer, skal erstatte deres filer med nye versioner ved at genindlæse dem via Mac App Store ved hjælp af købt historie. godbidder påpeger, at nogle ældre versioner af OS X, som Lion, ikke kan downloades på nyere maskiner. Brugere, der ikke kan erstatte et udløbs certifikat, kan stadig bruge ældre installatører ved at ændre datoerne på deres maskiner.

Hvis du er midt i en OS X-installation og får udløst det udløbne certifikat, tilbyder Randy Singer et forslag til, hvordan du hurtigt kan løse problemet uden at skulle downloade et nyt installationsprogram:

1. I OS X Installer skal du vælge Hjælpeprogrammer> Terminal.

2. Indtast dato 0201010116, og tryk på Retur.

3. Afslut terminal og fortsæt installationen.

Denne Terminal-kommando indstiller din systemdato til 1 Februar 2016 - inden certifikatets udløb - så installationsprogrammet kan fortsætte. Når du har afsluttet installationen, skal du besøge Systemindstillinger> Dato og klokkeslæt for at nulstille systemdatoen.

Apples certifikatfornyelsesproces resulterede i nogle problemer for udviklere og Mac-brugere tilbage i november, da det forårsagede, at flere apps i Mac App Store viste en "beskadiget" fejl og ikke kunne åbne. Æble hurtigt adresseret problemet og har hjulpet udviklere overgang til det nye certifikat.

Giv en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.