Razer Peripherals Configuration GUI Polychromatic 0.3.8 Udgivet Med Overhalet Bakke / AppIndicator

polykromatisk, en uofficiel GUI og bakkeapplet til konfiguration af Razer-periferiudstyr på Linux, blev opdateret til version 0.3.8 i dag, hvilket giver en fuldstændig omjusteret bakke / AppIndicator-applet, der kun viser valgmuligheder, der er relevante for din enhed, sammen med andre ændringer.
Polychromatisk Razer konfigurationsværktøj
Polychromatiske anvendelser Razer-drivere (uofficiel) under emhætten, som understøtter ganske få Razer-enheder, herunder:

  • tastaturer: BlackWidow Chroma og Chroma v2, BlackWidow Ultimate 2013 og 2016, BlackWidow Classic, BlackWidow X Ultimate, Ornata, DeathStalker Chroma;
  • mus og musematter: DeathAdder Chroma, DeathAdder Elite, Firefly, Mamba, Mamba Turneringsudgave, Naga Hex og Hex v2, Razer Ouroboros 2012;
  • Andre enheder: Blade Pro, Blade Stealth, Kraken 7.1 Chroma og V2, Razer Core.

For en komplet liste over understøttede Razer-enheder kan du tjekke ud DETTE .
Ved hjælp af Polychromatic kan du ændre effekter, lysstyrke og farvemetoder og oprette applikationsprofiler, selvom det ikke synes at være understøttet af mus - eller i det mindste har jeg ikke denne mulighed for min Razer Ouroboros-mus.
Fra den polychromatiske bakke-applet kan du hurtigt indstille effekter, lysstyrke og tilstande, ændre applikationsprofiler og DPI på flugt og meget mere.

Polychromatisk bakkeapplet kører i Linux Mint 18.1 (kanel)

Ændringer i polychromatisk 0.3.8 omfatter:

  • overhalet bakkeapplet / AppIndicator:
    • Vis kun valgmuligheder, der er relevante for den valgte enhed;
    • du kan nu bruge den til at ændre musen DPI;
    • mproved support til enheder, der har separate logo / scroll belysning muligheder;
    • viser den aktuelle status for effekter, lysstyrke, DPI og farve;
    • viser gemte farver og tillader skifte mellem dem;
    • Der blev tilføjet en ny mulighed, som muliggør genstart af Razer-driverens dæmon;
  • controller:
    • forbedret valg for at ændre ikoner;
    • Makroer, spiltilstande og profiler viser kun, om enheden understøtter dem;
    • Ultimate (ikke-RGB) tastaturer præsenterer nuancer af grønt;
    • UI forbedringer og forskellige under hood hoods.

To funktioner blev midlertidigt faldet med Polychromatic 0.3.8. Opstart indstillinger er ikke længere tilgængelige, fordi det var upåliteligt, selv om dette skulle komme tilbage med den næste store udgivelse. Den anden funktion, der blev midlertidigt tabt, er daemon-mulighederne, fordi den nyeste demonversion ikke læser dem.
Desuden er der med denne udgivelse polychromatiske pakker til rådighed for Fedora og openSUSE.
Bemærk, at den nye mulighed for at ændre DPI fra musen fra bakkeappletet tilsyneladende ikke har mulighed for at konfigurere DPI-værdierne. For min Razer Ouroboros-mus lister den på 5-scanningsopløsninger, som jeg formoder, er hvad musen som standard giver.
Også i min test under Ubuntu 17.04, når du ændrer DPI fra den polychromatiske bakkeapplet, er den aktuelle DPI-værdi, der vises, "0" i stedet for den aktuelle værdi. Dette opstod dog ikke under min test under Linux Mint 18.1.
For et alternativ til Polychromatic kun til mus, bruger det ikke Razer Drivers under hætten (nyttigt, hvis Razer Drivers ikke understøtter din enhed, eller hvis du har problemer med det), vil du måske se på RazerCfg.

Installer Polychromatic (og Razer Drivers) i Ubuntu eller Linux Mint

Inden du installerer Polychromatic, skal du installere Razer Drivers fra sin officielle PPA. Bemærk, at for at kunne installere Razer-drivere skal du sørge for at "universet" -arkivet er aktiveret (via software og opdateringer)!
Hvis du vil tilføje PPA'en og installere Razer-drivere i Ubuntu 17.04, 16.10 eller 16.04 / Linux Mint 18, skal du bruge følgende kommandoer:

sudo add-apt-depot ppa: terrz / razerutils sudo til at opdatere sudo til at installere python3-razer razer-kernel-moduler-dkms razer-daemon razer-doc sudo modprobe razerkbd

Bemærk: Razer-driverne PPA indeholder pakker til Ubuntu 14.04 / Linux Mint 17, men Polychromatic virker ikke med denne Ubuntu-version, fordi det afhænger af webkit2gtk, som ikke er tilgængelig for Ubuntu 14.04.
Nu kan du installere Polychromatic ved at bruge sin officielle PPA. For at tilføje PPA'en og installere den i Ubuntu 17.04, 16.10 eller 14.04 / Linux Mint 18, skal du bruge følgende kommandoer:

sudo add-apt-depot ppa: lah7 / polychromatic sudo apt opdatering sudo apt install polychromatic

Hvis du ikke vil tilføje den polychromatiske PPA, kan du downloade deb fra sin GitHub udgivelser .
Polychromatic Tray Applet og Controller er tilgængelige som separate emner i menuen / Unity Dash, så du skal starte dem separat.
Hvis din Razer-enhed er opført på listen over understøttede enheder, men ikke detekteres af Polychromatic, skal du prøve at genstarte dæmonen, enten fra Polychromatic Controller (på fanen Daemon> Daemon Service> Restart) eller bakken (Avanceret> Genstart daemon) og / eller prøv at genstarte computeren.
For at installere Razer Drivers og Polychromatic i andre Linux-distributioner, se følgende sider:

Rapporter eventuelle fejl, du måtte finde på GitHub: polykromatisk | Razer-drivere.

Oprindeligt udgivet på WebUpd8: Daily Ubuntu / Linux nyheder og applikations anmeldelser.

Giv en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.