vim-plug: En smuk og minimalistisk vim plugin manager til Unix og Linux brugere

En vim plugin manager er et must for enhver die-hard vim bruger. Du kan finde et par muligheder tilgængelige derude. Min personlige favorit er vim-plug, som er et smukt og minimalistisk plugin til vim. Lad os se, hvordan du installerer og bruger dette plugin på Linux eller Unix-lignende system.

Installation

Naturligvis skal du have vim installeret på dit system. Til demo formål bruger jeg Ubuntu og MacOS. Simpel download plug.vim og læg den i "autoload" biblioteket:
$ mkdir ~ / .vim / autoload / $ cd ~ / .vim / autoload /
Lad os gribe plug.vim enten ved hjælp af kommandoen wget command or curl:
$ wget https://raw.githubusercontent.com/junegunn/vim-plug/master/plug.vim
OR
$ curl -O https://raw.githubusercontent.com/junegunn/vim-plug/master/plug.vim

Hvordan konfigurerer jeg vim-plug?

Syntaxen er som følger i ~ / .vimrc:

"Angiv en mappe til plugins call plug # start ('~ / .vim / plugged')" Enhver gyldig git-URL er tilladt for plugin Plug 'gyldig git-URL' "Shorthand notation for plugin Plug 'foo / bar'" Initialiser plugin system call plug # end ()

"Angiv en mappe til plugins
call plug # start ('~ / .vim / plugged') "Enhver gyldig git-URL er tilladt for plugin
Plug 'gyldig git-URL' "Shorthand notation for plugin
Plug 'foo / bar' "Initialiser plugin system
call plug # end ()

Eksempel

Lad os sige, at du vil bruge et vim-plugin, der hedder ansible-vim for syntax, der fremhæver Ansible's fælles filtyper. Du skal tilføje følgende i din ~ / .vimrc-fil:

call plug # start ('~ / .vim / plugged') Plug 'pearofducks / ansible-vim' call plug # end ()

call plug # start ('~ / .vim / plugged')
Plug 'pearofducks / ansible-vim'
call plug # end ()

Gem og luk filen.

Installer ansible-vim plugin

Start teksteditoren:
$ vim
For at se status type type:

: PlugStatus

For at installere ansible-vim type:

: PlugInstall

Prøve session:

Animeret gif 01: Vim-plug in action

Animeret gif 01: Vim-plug in action
For at opdatere plugins type:
: PlugUpdate
Til ugrade vim-plug selv type:
: PlugUpgrade
Selvfølgelig, hvis du er tilfreds med vundle eller patogen, så er du nødt til at skifte. Men jeg kunne godt lide denne bedre. For mere information se den officielle GitHub repo.
Kilde

Giv en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.