Vin 1.9.24 Udgivet; Installer vin på Ubuntu 16.10 og Ubuntu 16.04-systemer

Vin 1.9.24 udgivet. Sådan installeres Wine 1.9.24 (Stable) via PPA på Ubuntu 16.10 og Ubuntu 16.04 Systems. Brug af Vin kan brugere køre Windows-software på Ubuntu.

Vin (oprindeligt et akronym for "Vin er ikke en emulator") er et kompatibilitetslag, der kan køre Windows-applikationer på flere POSIX-kompatible operativsystemer, som Linux, Mac OSX, og BSD. I stedet for at simulere intern Windows-logik som en virtuel maskine eller emulator, oversætter Wine Windows API-opkald til POSIX-opkald på flyet, hvilket eliminerer ydeevnen og hukommelsesstrafikken af ​​andre metoder og gør det muligt for dig at integrere Windows-applikationer på skrivebordet.

Vin 1.9.24

Vin 1.9.24 bringer støtte til uordnede adgangsvisninger i Direct3D. Det giver også nogle flere forbedringer i HID support, alingwith forskellige fejlrettelser og mange rettelser i regressionstestene.

Fejl fastgjort i 1.9.24 (total 28):

33636 vin cmd: ugyldig opførsel af '&' operatør
35343 dialog windows er for store
35658 Anthem Room Correction 2 v1.0.1 rapporterer 'Ukendt COM fejl 0x80004001' (brug for IAudioEndpointVolume :: GetVolumeRange metode implementering)
36115 kabinet / fdi test viser nogle valgrind advarsler
38768 Stronghold 2 hænger, når den startes.
39724 Need for Speed ​​Underground 2 styrter efter flere minutters spil
39734 ProtectDisc Driver 11: acedrv11.sys nedbrud
40366 Avatarika installer fejler
40595 gdiplus: metafile testregression (test_frameunit)
40596 gdiplus: metafile testregression (test_nullframerect)
40695 Crash i Fallout New Vegas
40791 N-Ball editor viser kun en blackscreen
40996 Deus Ex: Human Revolution mangler at starte, når du bruger DX11 renderer
41021 Zombie Army trilogi har brug for msvcr100.dll._fpieee_flt
41087 UE4-spil (forsvindingen af ​​Ethan Carter Redux, The Solus Project) crash under læsning med "D3D11Query.cpp: 139 # med fejl E_INVALIDARG"
41090 Flere spil (Starcraft 2, UE4 spil) kræver vcruntime140.dll .__ intrinsic_setjmp
41290 DirectShow-applikationer: MP3-afspilningen er brudt, hvis winegstreamer er deaktiveret
41308 iconfig.exe behov [Email protected]@[Email protected]@[Email protected]
41451 Motocross Madness: Manglende navne på spillere
41602-videoer afspilles ikke i Age of Empires
41640 tilføj rx 480 til directx.c
41671 GOG Galaxy kræver unimplemented funktion vcruntime140.dll .__ std_terminate
41683 Gauntlet start baggrund er beskadiget.
41695 LeagueClient.exe Ring til unimplemented funktion api-ms-win-crt-math-l1-1-0.dll.nearbyint
41705 Build fejler i dpnet: omdefinering af typedef 'SOCKADDR'
41719 crypt32: lagertestregression i testRegStoreSavedCerts ()
41721 hidtest.exe nedbrud på unimplemented funktion hid.dll.HidP_GetSpecificButtonCaps
41736 build error: configure detekterer udev kun delvis

Download Vin 1.9.24

Kilden er tilgængelig fra følgende steder:
http://dl.winehq.org/wine/source/1.9/wine-1.9.24.tar.bz2
http://mirrors.ibiblio.org/wine/source/1.9/wine-1.9.24.tar.bz2

Binære pakker til forskellige distributioner vil være tilgængelige fra:
http://www.winehq.org/download

Du kan også få den aktuelle kilde direkte fra git repository. Tjek http://www.winehq.org/git for detaljer.

Installer vinstabil 1.9.24

Før du begynder at installere Wine 1.9.24, skal du køre følgende kommando for at afinstallere og fjerne gamle Vinpakker, hvis de er installeret:
sud apt-get opdatering sudo apt fjerne vin * && sudo apt autoremove
Når først den ældre version af Wine er fjernet, tilføj den nye Wine PPA via disse kommandoer:
sudo add-apt-depot ppa: jonathonf / wine sudo apt opdatering sudo apt installere vinstabile
Der er også en anden metode til at installere WineHQ på Ubuntu Systems. Denne metode beskrives af det officielle vinhold. Hvis dit system er 64 bit, aktiver 32 bitarkitektur (hvis du ikke allerede har det):
sudo dpkg --add-arkitektur i386
Kør nu følgende kommandoer for at tilføje lageret og installer Vin:
sudo apt-get opdatering sudo add-apt-repository ppa: vin / vinbygger sudo apt-get opdatering sudo apt-get install - install-anbefaler vin-staging sudo apt-get install vinhq-staging
Det er det. Vin er installeret på Ubuntu System. Når du har installeret, skal du åbne Vin fra Ubuntu Dash og bruge den.

Vin 1.9.24 Udgivet; Installer vin på Ubuntu 16.10 og Ubuntu 16.04-systemer oprindeligt indsendt på Source Digit - Seneste teknologi, Gadgets & Gizmos.

Giv en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.