Comment installer Blender 2.92 dans Ubuntu 20.04, 20.10 via PPA

Blender 2.79

Pour ceux qui préfèrent installer des applications via la méthode apt classique, vous pouvez maintenant installer Blender 2.92 via PPA dans Ubuntu 20.04, Ubuntu 20.10, ainsi que Ubuntu 16.04, Ubuntu 18.04.

Le logiciel de modélisation 3D open-source Blender 2.92 est sorti il ​​y a quelques jours. Comprend «un tout nouveau flux de travail pour l'édition de maillages, de nouvelles méthodes de simulation physique, un rendu Cycles plus rapide, une meilleure composition avec Eevee, et bien plus encore.»

Blender propose le package Snap officiel, qui s'exécute dans le bac à sable, et peut être installé directement à partir du logiciel Ubuntu. De plus, un package portable Linux peut être téléchargé sur son site Web. Pour ceux qui préfèrent les paquets deb classiques, PPA de Thomas Schiex l'a fait pour les utilisateurs d'Ubuntu 20.04 et Ubuntu 20.10.

1. Ajoutez Blender PPA:

Commencez par ouvrir le terminal à partir du lanceur d'applications système. Lorsqu'il s'ouvre, exécutez la commande pour ajouter le PPA:

sudo add-apt-repository ppa: thomas-schiex / blender

Tapez le mot de passe de l'utilisateur, pas de retour d'astérisque, lorsqu'il le demande et appuyez sur Entrée pour continuer.

Le PPA ne prend pas en charge Ubuntu 16.04 et Ubuntu 18.04, mais un autre PPA le fait! Il nécessite cependant quelques PPA supplémentaires pour les bibliothèques mises à jour, voir le Description du PPA pour plus de détails.

2. Installez ou mettez à jour Blender:

Si vous avez une ancienne version des packages Blender installée via la méthode apt, ouvrez Software Updater (Update Manager) et mettez à jour le logiciel:

mise à niveau vers blender 2.79

Ou exécutez des commandes dans le terminal pour installer / mettre à jour le package:

sudo apt mise à jour sudo apt installer blender

3. Corrigez le problème de libLLVM-6.0.so.1 manquant:

Blender 2.92 ne démarre pas dans mon Ubuntu 20.04 et génère une erreur lors de l'exécution à partir du terminal:

/ usr / lib / blender / blender: erreur lors du chargement des bibliothèques partagées: libLLVM-6.0.so.1: impossible d'ouvrir le fichier objet partagé: aucun fichier ou répertoire de ce type

Cela peut être facilement corrigé en exécutant la commande:

sudo apt installer libllvm6.0

Je ne sais pas si le problème existe dans Ubuntu 20.10, mais libllvm6.0 n'est pas disponible dans le référentiel Groovy.

Désinstaller:

Pour supprimer Ubuntu PPA, ouvrez Logiciels et mises à jour et accédez à l'onglet Autres logiciels, puis supprimez la ligne correspondante.

Pour supprimer Blender installé via apt, exécutez la commande dans le terminal:

sudo apt remove --autoremove blender

Article original