Linux

HPLIP 3.22.4 Released with Manjaro 21.2 & New Printers Support

hplip-logo-250x250-1

HP printer and scanner drivers, HPLIP, released version 3.22.4 recently with a list of new devices support.

This release adds Manjaro 21.2 as well as following new printers support:

  • HP LaserJet Pro 4001ne, 4001n, 4001dne, 4001dn, 4001dwe, 4001dw, 4001d, 4001de,
  • HP LaserJet Pro 4002ne, 4002n, 4002dne, 4002dn, 4002dwe, 4002dw, 4002d, 4002de,
  • HP LaserJet Pro 4003dn, 4003dw, 4003n, 4003d, 4004d, 4004dn, 4004dw
  • HP LaserJet Pro MFP 4101dwe, 4101dw, 4101fdn, 4101fdne, 4101fdw, 4101fdwe
  • HP LaserJet Pro MFP 4102dwe, 4102dw, 4102fdn, 4102fdw, 4102fdwe, 4102fdne, 4102fnw, 4102fnwe
  • HP LaserJet Pro MFP 4103dw, 4103dn, 4103fdn, 4103fdw, 4104dw, 4104fdw, 4104fdn
  • HP ScanJet Pro 3600 f1
  • HP ScanJet Pro N4600 fnw1
  • HP ScanJet Pro 2600 f1
  • HP ScanJet Enterprise Flow N6600 fnw1

Download & Install HPLIP 3.22.4

HP provides official .run installer for all Linux users, simply download the package “hplip-x.xx.x.run” from the link page below:

Download HPLIP

Then right-click on the Downloads folder, select “Open in Terminal”, and finally run the installer via command:

./hplip-3.22.4.run

Follow the on screen prompts, and re-plug your printer when everything’s done successfully.

Install HPLIP 3.22.4 for Ubuntu 22.04:

The installer so far does not support Ubuntu 22.04. If you do require the new version, here’s how to manually install dependencies and built the package (Thanks to fostips).

Firstly, run the previous “./hplip-3.22.4.run” command will generate the source folder in Downloads. Right-click on it and select “Open in Terminal” to open terminal.

Next, run command to manually install dependency packages:

sudo apt install --assume-yes libcups2 cups libcups2-dev cups-bsd cups-client libcupsimage2-dev libdbus-1-dev build-essential ghostscript openssl libjpeg-dev libsnmp-dev libtool-bin libusb-1.0-0-dev wget python3-pil policykit-1 policykit-1-gnome python3-pyqt5 python3-dbus.mainloop.pyqt5 python-gi-dev python3-dev python3-notify2 python3 python3-reportlab libsane libsane-dev sane-utils xsane libavahi-client-dev libavahi-core-dev avahi-utils

Finally, run the commands below one by one in this terminal window to configure and build HPLIP (with source folder as working directory):

./configure --prefix=/usr --enable-qt5 --disable-qt4
make
sudo make install

It works in my case on Ubuntu 22.04 LTS.

Uninstall HPLIP 3.22.4

To remove the driver package, you need to first open terminal with source folder as working directory (See the last picture). When it opens, run the command to start uninstall script:

sudo ./uninstall.py

Same to the installing process, it will asks few questions to confirm during the process.

Original Article