Problemen oplossen "E: kan pakket niet vinden" Fout in Ubuntu [Beginnershandleiding]

    Deze zelfstudie voor beginners laat zien hoe u de E kunt oplossen: kan pakketfout niet vinden op Ubuntu Linux.

    Een van de vele manieren om software in Ubuntu te installeren is het gebruik van de apt-get of de apt commando. U opent een terminal en gebruikt de programmanaam om deze als volgt te installeren:

    sudo apt install package_name

    Soms kunt u een fout tegenkomen tijdens het installeren van de applicatie op deze manier. De fout luidt:

    sudo apt-get install package_name
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package package_name

    De fout spreekt voor zichzelf. Uw Linux-systeem kan het pakket dat u probeert te installeren niet vinden. Maar waarom is het zo? Waarom kan het het pakket niet vinden? Laten we eens kijken naar enkele van de acties die u kunt ondernemen om dit probleem op te lossen.

    Oplossing 'Kan pakketfout niet vinden' op Ubuntu

    Kan pakketfout niet vinden UbuntuKan pakketfout niet vinden Ubuntu

    Laten we eens kijken hoe we dit probleem stap voor stap kunnen oplossen.

    1. Controleer de pakketnaam (nee, serieus)

    Dit zou het eerste moeten zijn om te controleren. Heb je een typefout gemaakt in de pakketnaam? Ik bedoel, als je het probeert installeer vlc en je hebt vcl getypt, het zal zeker mislukken. Typefouten komen veel voor, dus zorg ervoor dat u geen fouten hebt gemaakt bij het typen van de naam van het pakket.

    2. Werk de cache van de repository bij

    Als dit de eerste keer is dat u uw systeem gebruikt na de installatie, moet u de update-opdracht uitvoeren:

    sudo apt update

    Dit commando zal niet update Ubuntu direct. Ik raad aan om door de concept van Ubuntu-opslagplaatsen. Kortom, de opdracht 'apt update' bouwt een lokale cache van beschikbare pakketten.

    Wanneer u de installatieopdracht gebruikt, zoekt apt pakketmanager in de cache om het pakket en de versiegegevens op te halen en vervolgens te downloaden van de repositories via het netwerk. Als het pakket zich niet in deze cache bevindt, kan uw systeem het niet installeren.

    Wanneer u een nieuw geïnstalleerd Ubuntu-systeem hebt, is de cache leeg. Dit is waarom je het apt update commando moet uitvoeren direct na het installeren van Ubuntu of andere distributies gebaseerd op Ubuntu (zoals Linux Mint).

    Zelfs als het geen nieuwe installatie is, is je apt-cache mogelijk verouderd. Het is altijd een goed idee om het bij te werken.

    3. Controleer of het pakket beschikbaar is voor uw Ubuntu-versie

    Alright! U hebt de naam van het pakket gecontroleerd en het is correct. U voert de update-opdracht uit om het cachegeheugen opnieuw op te bouwen en toch ziet u dat het pakket niet kan worden gevonden.

    Het is mogelijk dat het pakket echt niet beschikbaar is. Maar u volgt de instructies op sommige websites en iedereen lijkt het zo te kunnen installeren. Wat zou het probleem kunnen zijn?

    Ik zie hier twee dingen. Het pakket is beschikbaar in Universe-repository en uw systeem heeft het niet ingeschakeld of het pakket is niet volledig beschikbaar op uw Ubuntu-versie. Raak niet in de war. Ik zal het je uitleggen.

    Eerste stap, controleer de Ubuntu-versie die u gebruikt. Open een terminal en gebruik de volgende opdracht:

    lsb_release -a

    U krijgt het Ubuntu-versienummer en de codenaam in de uitvoer. De codenaam is hier belangrijk:

    [email protected]:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 18.04.3 LTS
    Release:	18.04
    Codename:	bionic
    Ubuntu-versiecontroleUbuntu-versiecontrole
    Ubuntu-versiecontrole

    Zoals je hier kunt zien, gebruik ik Ubuntu 18.04 en de codenaam is bionische. Je hebt misschien iets anders, maar je begrijpt wat je hier moet noteren.

    Zodra u het versienummer en de codenaam hebt, gaat u naar de Ubuntu-pakkettenwebsite:

    Ubuntu-pakketten

    Scroll een beetje naar beneden op deze pagina en ga naar het gedeelte Zoeken. U ziet een trefwoordveld. Voer de pakketnaam in (die niet door uw systeem kan worden gevonden) en stel vervolgens de juiste distributiecodenaam in. De sectie moet 'elke' zijn. Wanneer u deze drie details hebt ingesteld, drukt u op de zoekknop.

    Ubuntu-pakket zoekenUbuntu-pakket zoeken
    Ubuntu-pakket zoeken

    Dit laat zien of het pakket beschikbaar is voor uw Ubuntu-versie en zo ja, tot welke repository het behoort. In mijn geval zocht ik naar Shutter screenshot-tool en dit is wat het me liet zien voor de Ubuntu 18.04 Bionic-versie:

    Zoekresultaat pakketZoekresultaat pakket
    Zoekresultaat pakket

    In mijn geval komt de pakketnaam exact overeen. Dit betekent dat de pakketsluiter beschikbaar is voor Ubuntu 18.04 Bionic maar in de 'Universe-repository'. Als u zich afvraagt ​​wat de Universe-repository is, alstublieft verwijs naar het Ubuntu repository-artikel dat ik eerder had genoemd.

    Als het beoogde pakket beschikbaar is voor uw Ubuntu-versie maar het een repository is zoals universum of multiversum, moet u deze extra repositories inschakelen:

    sudo add-apt-repository universe multiverse

    U moet ook de cache bijwerken, zodat uw systeem op de hoogte is van de nieuwe pakketten die beschikbaar zijn via deze repositories:

    sudo apt update

    Als u nu het pakket probeert te installeren, zou alles goed moeten zijn.

    Niets werkt, wat nu?

    Als de Ubuntu-pakkettenwebsite ook aantoont dat het pakket niet beschikbaar is voor uw specifieke versie, moet u een andere manier vinden om het pakket te installeren.

    Neem bijvoorbeeld Shutter. Het is een uitstekende screenshot-tool voor Linux maar het is in jaren niet bijgewerkt en daarom heeft Ubuntu het uit Ubuntu 18.10 en nieuwere versies laten vallen. Hoe installeer ik het nu? Gelukkig heeft een externe ontwikkelaar een persoonlijke repository (PPA) gemaakt en die kunt u daarmee installeren. [Lees deze gedetailleerde gids voor PPA begrijpen in Ubuntu.] U kunt naar pakketten en hun PPA zoeken op de Launchpad-website van Ubuntu.

    Houd er rekening mee dat u geen willekeurige (onofficiële) PPA's aan uw lijst met opslagplaatsen moet toevoegen. Ik raad aan vast te houden aan wat uw distributie biedt.

    Als er geen PPA's zijn, kijk dan op de officiële website van het project en kijk of ze een aantal alternatieve manieren bieden om de applicatie te installeren. Sommige projecten bieden.DEB-bestanden or AppImage bestanden. Sommige projecten zijn overgeschakeld naar Snap-pakketten.

    Met andere woorden, controleer de officiële website van het project en controleer of zij hun installatiemethode hebben gewijzigd.

    Als niets werkt, is misschien het project zelf stopgezet en als dat het geval is, moet u op zoek naar de alternatieve toepassing.

    Uiteindelijk…

    Als u nieuw bent bij Ubuntu of Linux, kunnen de dingen overweldigend zijn. Dit is de reden waarom ik enkele basisonderwerpen zoals deze bespreek, zodat u een beter begrip krijgt van hoe dingen in uw systeem werken.

    Ik hoop dat deze tutorial je helpt bij het omgaan met de pakketfout in Ubuntu. Als u vragen of suggesties heeft, kunt u deze stellen in het opmerkingengedeelte.