Install Lollypop GNOME Music Player On Ubuntu Systems

Advertisements

Install Lollypop on Ubuntu 15.10, Ubuntu 15.04 and Ubuntu 14.04. Lollypop is a GNOME music player application for Linux Systems. Lollypop is a Rhythmbox alternative. It is an open-source audio player developed in GTK+3. It supports various popular audio formats, including mp3, mp4, ogg and flac. It can also be used to visualize the songs via album, artist or genre. The music player has two UI – White and Black.

Features:

  • mp3/4, ogg and flac.
  • Genre/Cover browsing
  • Genre/Artist/Cover browsing
  • Search
  • Main playlist (called queue in other apps)
  • Party mode
  • Replay gain
  • Cover art downloader
  • Context artist view
  • MTP sync
  • Fullscreen view
  • Radios support
  • Last.fm support
  • Auto install codecs
  • HiDPI support
  • Tunein support

Run the following commands in Terminal to install Lollypop on Ubuntu 15.10, Ubuntu 15.04 and Ubuntu 14.04:


sudo add-apt-repository ppa:gnumdk/lollypop
sudo apt-get update
sudo apt-get install lollypop

How to Build From Git (Ubuntu 14.04/15.04 are not supported!) :

$ git clone https://github.com/gnumdk/lollypop.git
$ cd lollypop
$ ./autogen.sh
$ make
# make install

In case you want the integration with Last.fm to work you need to install pylast

# apt-get install python3-pip
# pip3 install pylast

On Debian (Jessie)

$ git clone https://github.com/gnumdk/lollypop.git
$ cd lollypop
# apt-get install autoconf libglib2.0-dev intltool yelp-tools libgirepository1.0-dev libgtk-3-dev
$ ./autogen.sh
$ make
# make install

Instead of make install you might want to use checkinstall

# apt-get install checkinstall
# checkinstall

This will allow you to uninstall Lollypop as a package, for example with apt-get uninstall lollypop.

Advertisements

Leave a Reply